Feeder escape "\" comma doesn't work for me.


My csv file has a row of data “Ed, Edd 'n Eddy”, I tried using “” to escape comma to get the full string as “Ed, Edd 'n Eddy”, but it didn’t work, always got me “Ed” only.

My test sample:
val csvFeeder = csv(“testFile”, “\”).circular, this one didn’t work.

Also tried
val csvFeeder = csv(“testFile”, “”).circular, got syntax error.

Anyone tried using escape comma in Feeder, please advise…


Why don’t use the TSV format? Use tab as separator.


This looks like a feature that wasn’t properly backported when we dropped opencsv.
Will have a look.

This was indeed a regression: https://github.com/excilys/gatling/issues/1204
The fix will be shipped in 1.5.2.

Until then, could you use another separator that doesn’t conflict with your text content, as Nicolas suggested?

Thank you for your reply, Stéphane.

But my data files were created by CsvWriter and they are runtime generated, seems I will have to wait for your fix in 1.5.2 then.


Which CsvWriter are you talking about? The opencsv class?

I’m using com.github.tototoshi.csv.CSVWriter to save my runtime data to a csv file.