Gatling 3.0 and gRPC

Hello, i’m trying to load test our gRPC service with gatling 3.0.
As i know official gatling dont support gRPC, so i found gatling-grpc project on github.
but cant understand how to use it. It have poorly documentation and even worse that i’m newbie to scala and autotest.

Hi Bes,

Have you tried my version?

The project you linked has their specific gRPC service hard coded into the Gatling actions. It is unlikely that it can suit your need.
Giving credit where it is due, it helped a lot in understanding what I had to implement, when I tried to stress test my gRPC service with Gatling a year ago.

I know a blog post is no substitute for documentation, but that story I wrote a while ago may be of help to get you started.

Good luck with your test!


Hi George,

Thank you for your article. I tried to follow your instructions from Medium post But I get following error.

/build.sbt:17: error: not found: value scalapb
“com.thesamet.scalapb” %% “scalapb-runtime” % scalapb.compiler.Version.scalapbVersion % “protobuf”

Seems, it’s not able to resolve scalapb. Am I missing something obvious?


Hi Jay,

I think it is probably that you don’t have the scalapb.sbt file.


I am using gatling and gRPC using instructions from here

What should I do to see the request and response in intellj console?

I have no idea what you mean by “in intellij console”
But you probably want to turn on logging.


Thanks adding the logging helped.

Hello there,

is there a way to use authentication while using this plugin for gRPC?