Gatling Hanging??? No response...No Console Logs..


I am using the gatling for stress testing in our project. I have defined the scenarios and prepared the injection profile. All the scenarios are working properly and gatling gave nice report when the number of users is less, but when I run with large number of users, say 200 users/sec, execution hung in just 2 mints and nothing happened visibly (no console logs/response).

I have modified the following JVM variables to provide enough memory to gatling to run the scenarios.


The Java process of the gatling is 99% CPU Usage and been running but there is no console logs which shows the progress of the execution.

I am just trying to figure out what could be the problem. Can someone help me out?


Hi Dinesh,
Per my other email, I suspect you have overloaded the system under test and also your load injector machine.
Review once you inject 0.056 users per second, per your original requirement, or restate the requirements.

Also I wouldn’t set the new space to 100M (the -Xmn). likely worth removing that setting.


99% CPU usage seems crazy.
Looks like a JDK bug. Which version do you run? On which platform? Could you try getting a thread dump and see what happens here, please?

My Test actually ran for about 6 to 8 hours and then gatling crashes with out of memory errors. The thread dump was huge, around 6 GB. Even compressed file is about 600 MB.

My JDK is 1.7.0_51 (64-bit)

As suggested by Alex, I am planning to run the test with the reduced load and see if both the systems sustain the load. If the systems can sustain the load I am planning to run couple of gatling instances which can pump in the targeted load on my application under test.

Please drop your suggestions.

Thanks in advance.

This can happen for many reasons. Usually a misusage.
Could you upload the compressed heapdump somewhere, please? Impossible to tell without it.

Thanks for your quick reply. I have uploaded the compressed java dump file on the dropbox and copied the link below.


ETA: 7hrs
Will probably have to download tonight… :wink:

@Dinesh: Which version of Gatling do you use and what does your injection profile look like?

Honestly, I suspect that you’re running a version prior to RC3:

Hi Stéphane,

As you rightly said, I am using an older version (2.0 RC2) of gatling. I just now upgraded to 2.0.1 and restarted my test. Test seems running fine. I will keep you updated on the progress.

Thank you for your time!!!


I was pretty sure of it.
Have fun!

It worked fine. There were no memory issues. Thanks a lot for your support.