Gatling Http Request is timeout in 60 seconds


I am facing issue with gatling where HttpRequest is getting timed out in 60 seconds.
The scenario that I am testing is, I am importing 1000 users into our system which will take more than 10 minutes. When I triggered the import, Gatling captured the stats till 60 seconds and then it stopped. Please see below highlighted console logs.

I am using Java™ SE Runtime Environment (build 1.8.0_221-b11)
and below is my gatling versions


Exactly what is your question? Why did it time out?

Given what you have given us, the most likely answer is because your server took longer than 60 seconds to respond. It appears you only sent one request, not 1000, and that one failed due to a timeout.

To be more helpful than that, you’ll have to go into more detail about how your code is structured.

Thanks for the Reply.

Yes the request takes more than 60 seconds. But I do not want the request to timeout.

I think I solved this!
I am using maven to run my Simulation.
mvn gatling:test -Dgatling.simulationClass=uam.simulation.usersimport.ImportUsersSimulation

I modified gatling.conf file and modified gatling.http.ahc.requestTimeout to some higher value. But still it did not work.

When ran mvn clean install and then running the simulation agian worked for me.

Below worked:

mvn clean install

mvn gatling:test -Dgatling.simulationClass=uam.simulation.usersimport.ImportUsersSimulation