Gatling Script runs successfully, but does not really hit the target site

Hello -

I am pretty sure that I asked this question before, but I still have not solved my mystery.

I built a Gatling script using a HAR file generated using Google Chrome. It was tedious to debug, but I got that part of the script to “work” — except it really didn’t. Though every step returns a 200, nothing seems to show up in the APM tool.

When I generate Response bodies, I don’t see anything that tips me off.

So, I then built a LoadRunner script of the exact same activity, and I can see the results in the APM tool.

I then dissected the LoadRunner script, and I added the “missing” pieces of code from LoadRunner to Gatling. Note: If I was really ambitious and smart, I would build a tool to convert from LoadRunner to Gatling. That would be so cool.

Anyway, I have run the Gatling script through the logback.xml DEBUG mode and cannot find anything to tell me what is going wrong.

What else can I do to figure out where things are going sideways?

Someone told me to run the script through Fiddler, but I do not have much skill there. I can get Fiddler to capture the traffic, but I am not sure how to interpret what I see.


P.S. My journey with this script started last November. You might even have a recollection of all of my queries. I am getting better. Just still not there.

Though every step returns a 200, nothing seems to show up in the APM tool.

What makes things show up in your APM tool? Are you expecting something like this?
If so, you have to configure some custom HTTP headers on your requests so the APM tracks them.

Thanks for the response, Stephane, but, unfortunately, it does not help me find an answer.

Our APM tool, AppDynamics, is configured to monitor all activity at many layers of the application infrastructure — right down to Java methods and JDBC calls. In the LoadRunner script running 20 VUsers over 10 minutes, I can see 587 application logins and an equal number of business transactions. In the exact same (i.e., identical) Gatling flow, I see nothing at all. 0

I know that I am getting to the authentication section of the application because I am able to capture the SAMLResponse, stateToken and UUID. Note: App Dynamics does not “see” activity until the user gets logged in. If the Gatling “users” are getting logged in, they simply are not showing up.

I am going to see if our Okta team can see something causing all of the Gatling users to be derailed.


P.S. I know that LoadRunner is expensive, which is why I am trying so hard to replace it with Gatling. A 500 user LoadRunner license just cannot cut it.

Some people are using Gatling successfully with SAML for sure, eg: (use Google Translate).

Hi Randy,

How did you get on with dealing with Okta in regards to Gatling? I like you, came from LoadRunner and have been struggling a bit with Gatling documentation, it assumes too much I’ve found. A Gatling For Dummies book would be a godsend for me.
My issue at the moment is trying to find the okta state token, I can’t find a previous response to take it from so can’t send it in a subsequent request. I’ve also got device fingerprint and okta xsrf token to deal with also, so that’s fun!

Kind regards,


Have you had a look at the documentation and the Gatling Academy?

Hi Stephane,

Yes thanks, I’ve completed both modules of the Gatling Academy, and have read the documentation, still a bit stuck. I’d like if the Cheat Sheet had some real world examples, would be nice to see how a lot of functions are used in the context of a script.
As soon as I can crack this Okta auth I should be able to move forward and the rest of Gatling will make sense hopefully!