Gatling setup is very very difficult whereas using Gatling is 10 x times easy

Speaking from my experience and what I have generally observed while working with Gatling is that,
The setting up Gatling to use it is 10x times difficult than actually using it.
In fact, it is ruining the whole experience which comes with this beautifully simple performance testing tool.
You may look upon any of the online tutorials which teach Gatling and you can find, that most of the students are stuck with the Gatling setup part - be it the Java version mismatch, maven/Gradle version mismatch or something else altogether. It’s acting like a funnel filter where only a handful gets through.
I have spoken with a couple of my colleagues who had explored Gatling as an alternative to Jmeter and what they have told me goes hand-in-hand with what I have mentioned here.
Every single one of them agrees that, besides strong community support, if Gatling setup was as easy as it was for JMeter, most of them would give Gatling a shot.
A humble request to the makers of Gatling from a Gatling tool aficionado :
Please do something about the setup. Please automate it. Anything to ease the pain in the setup of Gatling would be highly appreciated

Have you taken the time to read the documentation, typically:
In particular, regarding maven, we provide both an archetype and a sample:
Regarding gradle, we don’t officially support it, so no wonder you don’t find any information about it.

Now, if you feel some bits are missing, please contribute (see Contribute: Edit this page on Github link on the right side of each documentation page).


I understand that the Gatling model is different from Jmeter. My suggestions were purely based on my experience in using the tool and not in any way downgrade the tool itself.
I admit that I do not have enough knowledge to contribute to the development part of the tool; however, I was hoping if someway I can contribute to enhancing the user experience in using the tool by providing honest feedback, so be it.

Gatling is not complicated if you stick to the trodden path (using the recommended/supported project approach and build tool), but does indeed get a bit tricky if you try to do something fancy (I spent a few days trying to find how to unpack protobuf responses - but I guess it’s more because of my ineptitude with Scala).

If you have any particular problem, post them in the user group, the community is helpful.


It is indeed, no doubts about it at all.
But the struggle you face when you deviate from the ‘happy path’ is what I was hinting at, but not necessarily in that sense. In a way or the other, in my opinion, major issues with Gatling originate from the setting up of the application (like version mismatch). But once you do, it works like clockwork.

Could you please elaborate on the path you took for setting up and how/why it was hard?

Did you follow the official documentation?
An outdated version of our documentation (we’re working on fixing SEO so that doc for obsolete versions don’t show up first)?
A third party, possibly outdated, blog post?

Hi Stephen,

Just to be sure, I have re-installed Gatling based on the recommendation from the page to get a better understanding. Here’s my feedback:

  1. The Pre-Requisite setup (Java, Maven, & Scala) :

  1. Java Class path:

  1. After setting up these configurations, I have done a maven archetype to create a project and made src as the source directory.
  2. I wrote a simple gatling script to test it. Here’s the script -

  1. I have attached the pom.xml file for reference where I believe I have covered most of the dependencies and plugin configurations (please feel free to correct me)
  2. Lo and behold, I got this error -

Now, clearly this has something to do with some of the configurations.
But what I would like to highlight here is, if you really look at it, this is a correctable error. We are talking about a couple of dependencies or plugins which are always required for Gatling to ensure optimum usage. Or its an issue with IntelliJ itself. (btw too much dependency here, not that I am complaining)

I have had somehow corrected this error in the past, but I couldn’t retrace my steps to get to that solution now.
Correcting such errors is a time-killer and a kill-joy in itself which drains energy and efforts.
I was wondering if we could just make some sort of shell script which would auto-add those dependencies or plugins by default (the basic ones), the rest of the process is a cake wake.
I do understand what I am looking for is similar to a fairy tale imagination but this is the part where I got stuck and so did many others.
I hope this helps.

Warm Regards,
Mishal Alexander

pom_file.txt (2.56 KB)

hi … I got the same error as well … but when I tried to execute the scala script from the command line , it worked fine… Then I downloaded the gatling demo and added my scala script to it and the project completed without error…
Later I got the reply mentioned in this link!msg/gatling/2TDLoWq4kgc/Sq9beulaAQAJ



So, making things more specific: this problem only happens:

  • with a project generated from the maven archetype (not when cloning the maven sample from Github, both ways are documented)
  • when running from the Engine class (not when running from gatling-maven-plugin)
    Your problem has already been reported here and taken care of here.

Until next release, you can either:

  • Update your project based on the commit above
  • Add a gatling.conf file like in the maven demo

I have also faced the similar issue of setting gatling due to incompatible dependencies, so to resolve that i have created a docker image by burning the relevant version with themselves, one just need to run two commands to setup and then they are good to run test cases…feel free to use this framework and share views if any :slight_smile:
One can use it as plug -n- play utility.

I have also faced the similar issue of setting gatling due to incompatible dependencies

Different problem. If you mix Gatling and your own application, there’s a chance you end up with dependencies conflicts, but this can happen with any JVM based solution. Don’t put Gatling and your app in the same classpath then.

I know this is late, and I was just going through some old posts to see if I could help with some of the issues.
I guess we can park this thread, as for me VS Code replacing IntelliJ makes things much easier.
Setting things up in IntelliJ was a nightmare (it might be different now but I don’t feel like trying it again coz VS Code baby!)
I find this setup super simple and straight-to-the-point.

So if anyone else is struggling, I highly recommend VS Code. The difference, from my experience, is day-and-night!
Here’s a blogpost which helped me (Note: I am not affiliated with the blog post author; I am sharing it here as a goodwill gesture) =