How to solve the Error with debug - logging : Cannot access 'io.gatling.gradle.JvmConfigurable.Trait.FieldHelper'?

Hi Gatling Community Team,

I need to check the log for performance execution on cursor based pagination scripts in jenkins.
but the build.gradle always shows error with log parameters such as at logHttp & logLevel

plugins {
    id("io.gatling.gradle") version "3.9.0"

gatling {
    logHttp = io.gatling.gradle.LogHttp.FAILURES
    logLevel = "WARN"

repositories {
    maven {
        url = uri("")

Error message :

Cannot access 'io.gatling.gradle.JvmConfigurable.Trait.FieldHelper' which is a supertype of 'io.gatling.gradle.GatlingPluginExtension'. Check your module classpath for missing or conflicting dependencies

Please help me solve this issue

Hi @RudraGanesh,

What is your version of gradle?
What is your version and vendor of the JVM?

Which command does produce such error?

And I think you should have logHttp = 'FAILURES'.


Hi @sbrevet ,
thanks for responding

please find the below details
Gradle : 7.5
Kotlin: 1.6.21
Groovy: 3.0.10
JVM: 11.0.12 (Azul Systems, Inc. 11.0.12+7-LTS).
error is not triggered by any command but its notified by IntelliJ as error and during execution there is no log generated for http failures.

I tried with logHttp = ‘FAILURES’ but i get below error
Type mismatch.

Old Gradle Kotlin DSL (would have helped to mention you were using this) compatibility issue.
Please upgrade your plugin version (the latest one as of now is

I tried to upgrade to
But i am getting 404 file not found error with maven path, is the version available in maven central?
should I adopt gradle file? please help me

00:17:38 INFO: Downloading:
00:17:38 ERROR: Error while downloading Unsuccessful download from
100% [ ] ETA: --:–:–
00:17:38 ERROR: Internal Error: Gatling download failed: No more links to try
00:17:38 INFO: Post-processing…

even when i adopt the file with " url = uri("“)” still it takes Central Repository: io/gatling/highcharts/gatling-charts-highcharts-bundle

What you are doing is nonsense.
You have the issue mentioned in this thread’s title because you are using an outdated version of the gatling gradle plugin, which I told you to upgrade.
And now you’re trying to use the bundle instead and use a version that doesn’t exist?!

Issue solved with a custom logback file.
and with bundle 3.9.1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.