JMS sendmessage to SQS


I have been following the below article for load testing with AWS SQS:

The example uses the textMessage method for sending a message. For my use case, I will need to send a nested map to SQS which will then be taken by an application. I tried using the mapMessage method but it seems to fail with:
17:08:19.253 [][ERROR][Action.scala:71] i.g.j.a.Send - ‘jmsSend-2’ crashed with ‘j.j.JMSException: Unsupported Method’, forwarding to the next one

I even tried sending the following:
mapMessage(“foo” → “bar”). That failed as well. Any help would be highly appreciated!
gatling version: 3.0.3

First thing first, Gatling 3.0.3 is very old.
Please upgrade to a modern maintained version (latest is 3.6.1) so people can try to help you.

Thanks for the quick reply. I checked the maven repo that was linked below:

Seems like the latest is 3.1.2. I did update to that but I still run into the issue.


Thanks for getting back to me! I did take a look at the maven repo and it seems 3.1.2 is the latest over there.

I did upgrade to that but I still run into this issue.


Versions of the maven plugin and of Gatling itself are not related.

Then, it simply seems the SQS JMS adapter doesn’t support Map messages.

Thanks for getting back to me Stephane! I do see that on the documentation for jms on gatling, it does mention that mapMessage is supported.

Also, in the what’s new section of 3.1, there is section that mentions added support for mapMessage.

So, just to clarify, does SQS JMS Adapter not support mapMessages then?


Supported message types

  • ByteMessage

  • ObjectMessage

  • TextMessage

=> No MapMessage