Plugin upgrade causes "No simulations to run"

I’m seeing an issue upgrading from gatling plugin 3.1 to 4.2 with “No simulations to run”

from
<gatling-plugin.version>3.1.0</gatling-plugin.version>
to
<gatling-plugin.version>4.2.9</gatling-plugin.version>
then I get this error,
[ERROR] No simulations to run

If I switch back to 3.1.0 the test runs fine.

Also it is noted the test-class folder only have resources, none of the classes compile with 4.2.9

Plugin config

            <plugin> <!-- https://gatling.io/docs/gatling/reference/current/extensions/maven_plugin/ -->
                <groupId>io.gatling</groupId>
                <artifactId>gatling-maven-plugin</artifactId>
                <version>${gatling-plugin.version}</version>
                <configuration>
                    <!-- https://gatling.io/docs/gatling/reference/current/extensions/maven_plugin/#working-with-gatling-enterprise-self-hosted -->
                    <runMultipleSimulations>true</runMultipleSimulations>
                    <!--                    The following command is to run one simulation at time-->
                    <!--                    $ mvn clean verify -DperformanceTestUtil.environment=dev -Dgatling.simulationClass=performancetest.simulations.ProcedureMacroSimulation
                    -->
                    <includes>
                        <include>scala.performancetest.simulations.InteractionSimulation</include>
                    </includes>
                </configuration>
                <executions>
                    <execution>
                        <goals>
                            <goal>test</goal>
                        </goals>
                    </execution>
                </executions>
            </plugin

So it look like 3.1.0 must have automatically called the scala libraries. When my SDET sugguested adding

      <plugin>
        <groupId>net.alchim31.maven</groupId>
        <artifactId>scala-maven-plugin</artifactId>
        <version>${scala-maven-plugin.version}</version>
        <executions>
          <execution>
            <goals>
              <goal>testCompile</goal>
            </goals>
            <configuration>
              <jvmArgs>
                <jvmArg>-Xss100M</jvmArg>
              </jvmArgs>
              <args>
                <arg>-deprecation</arg>
                <arg>-feature</arg>
                <arg>-unchecked</arg>
                <arg>-language:implicitConversions</arg>
                <arg>-language:postfixOps</arg>
              </args>
            </configuration>
          </execution>
        </executions>
      </plugin>

It started working… yeah!!!

So it appear you need to add the scala plugin after you upgrade to 4.x

      <plugin>
        <groupId>net.alchim31.maven</groupId>
        <artifactId>scala-maven-plugin</artifactId>
        <version>${scala-maven-plugin.version}</version>
        <executions>
          <execution>
            <goals>
              <goal>testCompile</goal>
            </goals>
            <configuration>
              <jvmArgs>
                <jvmArg>-Xss100M</jvmArg>
              </jvmArgs>
              <args>
                <arg>-deprecation</arg>
                <arg>-feature</arg>
                <arg>-unchecked</arg>
                <arg>-language:implicitConversions</arg>
                <arg>-language:postfixOps</arg>
              </args>
            </configuration>
          </execution>
        </executions>
      </plugin>

. Thanks A…

Hi @cap10bill,

Please, provide a full reproducer as a way we can investigate.

My guess is that you miss the alert box for scala users:

For Scala users only : starting from version 4, this plugin no longer compiles Scala code and requires to use the scala-maven-plugin when using Gatling with Simulations written in Scala. Please check the pom.xml of the demo project for maven and Scala mentioned above for complete configuration.

(source: Gatling - Maven Plugin - Setup documentation)

Does that help?

Cheers!

PS: Your own replies are correct (but was for review as they were automatically marked as spam).