Some Graphs are missing in Gatling Report 1.3.0


We are testing new Gatling 1.3.0 and we are happy with the new features on report :slight_smile:
But, we have some issue :

  • On Chrome, some graphs are empty, but the contextual window works
  • On FireFox, these graphs are correctly displayed, but, contextual window and timeline manipulation doesn’t work

In the attachment, we join the report. To see a “guilty” graph see :

the “Response Time during Simulation” disappear.

These Graphs works fine on 1.2.5 :slight_smile:

Best Regards,
Denis (900 KB)

These are maybe Highcharts bugs.
We’ll investigate.

2012/9/26 DeV@n <>

This is indeed a Highcharts bug that seems not to be able to handle 500+ plots on an area chart.
Until we get this fix, you can reduce the number of plots per series with the maxPlotPerSeries gatling.conf parameter. I was able to have correct charts with your log file with a 450 value.

Stay tuned.


2012/9/26 Stéphane Landelle <>

I have pushed a workaround.
You can tray the latest snapshot available here:



Thanks for your quickness.
We try your soluces :

  • The first one, (changing maxPlotPerSeries) works great, and the graph is present.
  • For the Second, (trying the 1.3.1 SNAPSHOT with workaround) the resulting graph shows weird values, also in Statistics chart. So, for the same request, reporting with the same simulation.log file :

Statistics In 1.3.0 :

Response Time (ms)

Total OK KO

Min 4 4 -
Max 16 16 -
Mean 7 7 -
Std Deviation 1 1 -
95th percentile 9 9 -
99th percentile 11 11

Statistics in 1.3.1 :

Response Time (ms)

> Total OK KO
Min 0 0
Max 10 10
Mean 0 0
Std Deviation 2 2
95th percentile 0 0
99th percentile 10 10

Hope it helps,


Until 1.3.1, charts generation had a 1 ms accuracy. Problems were that:

  • this could lead to huge heap usage when generating the reports
  • Such a precision is a non-sense as time measurement can’t be 1ms precise, moreover in multi-core async environments. Let’s keep in mind that the reports are intended for investigating problems, and that you don’t really care if your response time was 605ms or 600ms, what matters is the order (about 600ms).
    In 1.3.1, we’re introducing an accuracy parameter used during charts generation. Default value is 10 ms which is a quite reasonable duration accuracy under X systems.

If you want more precise values, you can set the parameter back to 1, but once again, it doesn’t really make sense.



2012/9/27 DeV@n <>

Ok :slight_smile:
We are agree with you, We didn’t notice the scale of values, and we didn’t know that the accuracy was changed.

Thanks !

You’re welcome.

We’ll document this when we’ll release 1.3.1.

FYI, this was indeed a Highcharts bug:



2012/9/27 DeV@n <>