Using Gatling with InfluxDB

Hi,

I’m following → https://gatling.io/docs/2.3/realtime_monitoring/

If I’m using InfluxDB as a datasource I don’t need Graphite aswell? Is this correct?

InFluxDB is installed on my Jenkins box -

10.88.20.67

where the Gatling Load is run from :-

[root@doc-lab-demo 457]# influx
Connected to http://localhost:8086 version 1.4.2
InfluxDB shell version: 1.4.2

show databases
name: databases
name

Try to restart the Influxdb. It’s necessary if you change the influxdb.conf

I have tried restating influxdb loads of times already :-

sudo service influxdb stop
sudo service influxdb status
sudo service influxdb start
sudo service influxdb status

Are there any logs I can look at to see if anything is happening?

This issue is solved…it wasn’t picking up my conf directory from build.gradle…I had to add the following :-

sourceSets {
    simulations {
        scala {
            srcDirs = ['src/test/gatling/user-files/simulations']
        }

        resources {
            srcDirs = ['src/test/gatling/user-files/simulations', 'src/test/gatling/user-files/data', 'src/test/gatling/user-files/body', 'src/test/gatling/conf']
        }
        compileClasspath += configurations.gatling
    }
}

Thanks For the Help,
Tina.

hii
i am also getting same issue that my gatling db is not forming in influxdb. Can you explain where i need to edit this

Hi, Can you tell me where can I put these changes in my framework of gatling?