I ran suddenly to "There is no simulation script. Please check that your scripts are in user-files/simulations" problem


I was running Gatling fine with Eclipse until now. I recorded a new scenario and I actually ran the simulation once successfully. But after some modifications to the scenario I can’t run any simulations. I get error “There is no simulation script…”. I tried removing the new scenario and rerun Engine but I still get the same error and I don’t seem to get rid of it. I don’t really believe the scenario is causing the problem. There must be something else wrong.

My project structure is: Engine, Recorder and IDEPathHelper are in a same package under src/test/scala. Scenario classes are under another package but they are also under the same source folder. src/test/scala is set as source folder. All the configuration files are under srec/test/resources which is also set as source folder. I can build the project without errors in Eclipse and in command line also. I’ve tried clean and build and update maven project from Eclipse but no help. I’ve also tried to remove the source folders from build path and set them again. I still get the error. It’s weird because everything was running fine just moments ago. Any help would be appreciated

Thanks in advance. Henri.

This error means that you have no class that extends Simulation in the target/classes directory.
I can only guess what happens: some IDE error, or maybe you accidentally removed “extends Simulation” from your simulation class?

I had to run maven build from command line and after that it works again. For some reason running maven build in Eclipse didn’t work. However, problem solved!

perjantai, 27. joulukuuta 2013 20.57.23 UTC+2 Stéphane Landelle kirjoitti:

Looks like a eclipse/m2e issue.
Thanks fro your feedback.

I am also running to same problem. It was working for past many days but doesn’t work after system restart though I have all files in right place & they extend to Simulation

There is no simulation script. Please check that your scripts are in user-files/simulations

*******:gatling-charts-highcharts-bundle-2.2.3 $$$$$$ ls user-files/simulations/computerdatabase/
BasicSimulation.scala advanced apisimulation.scala

Code →

class apisimulation extends Simulation

same problem here (yes, it is february 2018), i just copied gatling to another machine (win 10 → win 10), and suddenly there is no simulation script (tried permissions, run as admin, everythings looks good). no idea how to solve this.

proposal: error message should display ABSOLUTE path, maybe it searches somewhere else?
proposal: if the problem is elsewhere, then display APPROPRIATE error message, stack trace, whatever might help (“no simulation script” is really misleading)

solved! i modified gatling.bat this way: after the label “run:” i forced the java variable like so:
set JAVA="C:\Program Files (x86)\Java\jdk1.8.0_161\bin\java.exe"
i.e. the error message was misleading in this case

It was a compilation error in my case. For troubleshooting, set the log level to WARN in logback.xml:

This is my first 24 hours experiencing Gatling. I ran into this error message when trying to run Gatling.bat from the downloaded/extracted Gatling folder. After uninstalling and reinstalling Java, and removing and re-adding my system variables the error was still reproduced. Running the mvn compile command was unsuccessful. Finally, I opened the cmd window as an administrator and ran Gatling.bat and the error did not reappear.

@Gattaca Reinstalling everything was definitely overkill. You could have just deleted the target directory to remove the compiled files and trigger a full recompilation.