Running simulation using engine.scala in Eclipse IDE returns "There is no simulation script. Please check that your scripts are in user-files/simulations"


I am trying to run a simulation running Gatling2 from Eclipse Juno 4.2 SR2. I have followed the steps described her: and are able to start the recorder from Eclipse. When I try to run the engine.scala class it returns “There is no simulation script. Please check that your scripts are in user-files/simulations”.

I have tried to put the simulation file in the described path in several locations in the project but no luck so far. Can anybody tell me what the location of the simulation file should be?


Best regards,


This message is actually valid for the bundle.
Your simulations should be placed in src/test/scala.

Thanks for your answer.

I placed my simulation file in src/test/scala, but I still get the same message. I also tried to put my simulation file in in a user-files/simulations directory inside src/test/scala but no luck. Any ideas what could be wrong? Thanks!


Did you generate your project with the gatling maven archetype?
Did you properly install m2e and m2e-scala?

I used

mvn archetype:generate -DarchetypeGroupId=io.gatling.highcharts -DarchetypeArtifactId=gatling-highcharts-maven-archetype -DarchetypeCatalog=

to generate the project.

Eclipse version:Juno Service Release 2
Build id: 20130225-0426

m2e - Maven Integration for Eclipse - m2e
Maven Integration for Scala IDE Sonatype, Inc.

Did you also install Scala IDE? if so, did you pick the right update-site for Juno (beware that the first one to appear on their website is the one for Indigo)?
Note that you can generate a project from an archetype directly inside eclipse with m2e: new > Project > Maven > Maven Project

Could you share a screen capture of your project, please?

Dear Stéphane,

I found the problem: my project was still located in the default (on Windows) GitHub directory “My Documents\GitHub” I moved the project to a location without white spaces in the path and now my simulation runs fine from Eclipse! Thanks again for your time and answers!



Thanks for your feedback. I’ll add this in our documentation, other users might run into the same issue.