java.net.ConnectException: Address already in use: no further information

I am trying to run a “ping-test” against a static resource to test “the infrastructure”.
my load model is as follows:

setUp(scn.inject(constantUsersPerSec(1500) during (10 seconds))).protocols(httpConf)

after som time running I get:

`
15:06:38.138 [WARN ] i.g.h.a.AsyncHandlerActor - Request ‘shitload’ failed: java.net.ConnectException: Address already in use: no further information

`

The Gatling version is 2.1.4 and

What might be the cause?

You’re probably running out of ephemeral ports.

Ok, thanx.
I am running from a Windows Server 2012 R2.
Is there a way to “get more ephemeral ports”?

//Magnus

http://lmgtfy.com/?q=windows+change+ephemeral+port+range&l=1 :slight_smile:

Eh, sorry :slight_smile:

Ok, I have increased the ephemeral ports to 65.000 but when I run a test with 1500 users per second in 10 seconds the first time it is ok.
But when running it the second time I get:


java.net.ConnectException: Address already in use: no further information

When I run just one user I get the exception as well.

Do I need to terminate connections more than I have done in the example below? or tweak gatling.conf in someway? obviously the increase in ephemeral ports did not work.

`

package no.coop

import io.gatling.core.Predef._

import io.gatling.http.Predef._

import scala.concurrent.duration._

class isAlive extends Simulation{

val httpConf = http

.baseURL(http://grointtst.intrano.shell:88)

.acceptHeader(“text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8”)

.doNotTrackHeader(“1”)

.acceptLanguageHeader(“en-US,en;q=0.5”)

.acceptEncodingHeader(“gzip, deflate”)

.userAgentHeader(“Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0”)

val scn = scenario(“isAliveSimulation”)

.exec(http(“shellload”)

.get("/3mb.htm")

.check(regex(“8.png”)))

setUp(scn.inject(atOnceUsers(1))).protocols(httpConf)

//setUp(scn.inject(constantUsersPerSec(1500) during (10 seconds))).protocols(httpConf)

}

`

I also get:

`

java.net.ConnectException: No buffer space available (maximum 4 ( 0,27%)
connections reached?): connect

`