Connection timed out: no further information

Hi All,

I was trying to run gatling test on RESTFUL API (trying to run the BasicSimulation example) under my maven project.

Unfortunately, I keep getting Connection timed out

  1. no matter whichever URL I tried.
  2. even when i added the .disableWarmup

However, it works when I try to “gatling” localhost RESTFUL URL.

I would like to seek some advices to see what am I missing?

gatling-maven-plugin version: 2.0.0

Example Code
package restful // 1

import io.gatling.core.Predef._ // 2
import io.gatling.http.Predef._
import scala.concurrent.duration._

class Test extends Simulation { // 3

val httpConf = http // 4
.baseURL(“”) // 5
.acceptHeader(“text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8”) // 6
.acceptEncodingHeader(“gzip, deflate”)
.userAgentHeader(“Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0”)

val scn = scenario(“BasicSimulation”) // 7

.get("/")) // 9
.pause(5) // 10

setUp( // 11
scn.inject(atOnceUsers(1)) // 12
).protocols(httpConf) // 13

Could this be a proxy issue?

It might be proxy issue configured i preassume which is something i cannot change due to organization setup, still looking into it.

Have you tried setting the proxy in your requests?

Thanks for the feedback.

You are right. It is the proxy problem.

Hi Stéphane,

Do you think it would be a good idea to allow a proxy to be set in the gatling.conf?

Hi Aidy,

We try to avoid having many ways of doing the same thing: complexity, confusion and more code to maintain.
The provided way is the HttpProtocol.

Usually, you only need a proxy when you’re in dev mode.