Maven plugin and Graphite Configuration Issue

I’m unable to get results published to our Graphite server from the mvn task. I don’t think I’ve got it configured correctly and I’m a bit at my wits end as to why.

I’m not getting any error or anything, just nothing when I run mvn test. The test runs great. Fantastic tool!

Any help would be massively appreciated.

Thanks, Ryley

I’ve got this gatling.conf in src/test/resources

data {
writers = [console, file, graphite]
reader = file
graphite {
host = “”
port = 2003
bucketWidth = 100

and this is my pom

<project xmlns="" xmlns:xsi="" xsi:schemaLocation="">



			<name>Excilys Repository</name>

			<name>Excilys Repository</name>





Are you sure you don’t have any firewall issue with ?

This simple command will sort this point quickly
echo “foo 123 $(date +%s)” | nc graphite.internalDomain 2003

I just did a test and everything seems working fine for me.


Ok, solved this… and the solution is a bit embarrassing.

My gatling.conf file was not wrapped with

gatling {


That’s what I get for cutting and pasting from the doc w/ little understanding.

Thanks for the attempt to help.

No problem, I’m glad to hear that the issue is solved.
have a nice day