Maven plugin - specifying data directory outside of GATLING_HOME


I am using the maven plugin to execute my tests. I tried to specify the data directory in either gatling.conf or the pom file, but neither seems to be pointing to the correct directory, which is outside of $GATLING_HOME. What is the correct way of specifying the path to the data directory when using the maven plugin?


This group’s rules specify that you’re expected several things, like providing the versions you’re using.
Then, what have you tried exactly? You’re supposed to pass absolute paths.

My apologies for missing some key details. I am using gatling 2.1.2, same version for the maven plugin.

I have tried specifying the absolute path in either the pom file or gatling.conf, but neither works.

This is a plugin config example:

C:\feeders target/gatling/results src/test/resources/request-bodies src/test/scala

And this is in gatling.conf:

directory {
#data = user-files/data # Folder where user’s data (e.g. files used by Feeders) is located
data = “C:\feeders”
#bodies = user-files/bodies # Folder where bodies are located
#simulations = user-files/simulations # Folder where the bundle’s simulations are located
#reportsOnly = “” # If set, name of report folder to look for in order to generate its report
#binaries = “” # If set, name of the folder where compiles classes are located: Defaults to GATLING_HOME/target.
#results = results # Name of the folder where all reports folder are located

Do you define your configuration inside an execution? It looks like a maven regression causes it to not be honored?! If so, move it directly into the plugin block.


OK, it seems that per execution configuration is only honored when you have several executions, not only one.

OMG, this is not a bug, this is a “feature”: