Trouble customizing gatling.conf file directories


I’ve set the environnement var GATLING_HOME to my intelliJ workspace root directory, so as to say, C:\dev\ProjetsIntelliJ\benchsTrunk

All my simulations (scala classes that “extends Simulation”) are/will be located in the src/test/scala/*.scala directory.
I Tryed to customize the gatling.conf this way, so as to gatling could find the simulations :

directory {
#data = src/test/resources/data
#requestBodies = src/test/resources/request-bodies
#simulations = src/test/scala
#reportsOnly = “”
#binaries = “”
#results = results

When I run the Engine, the debug console logs this :

Connected to the target VM, address: ‘’, transport: ‘socket’
There is no simulation script. Please check that your scripts are in user-files/simulations
Disconnected from the target VM, address: ‘’, transport: ‘socket’

Process finished with exit code 0

What do I miss in the process, please?

I apologies for this stupid post…

You’d better use the maven archetype and generate a ready-to-go IDE integrated project.

Sincerely I tryed to use a maven archetype…
Could you please repost the archetype to use for gatling 2.0.3 in an IDE, please?

Thank you very much.

The procedure is documented here:
And the archetype is properly deployed on maven central:

What else?

I tried this procedure, but It never fully worked for me (for the 2.0.0 maven i allways get build error before the end) … I certainly do something the wrong way…
But my workspace is the same as described
I got it right with the 2.0.0M3, and then upgraded gatling to 2.0.3

thank you for your answers.

Old 2M3 archetype and artifacts were deployed on a private repository. Now, everything is on maven central, so you don’t need additional repositories.

for the 2.0.0 maven i always get build error before the end

Which is?

Are you sure you don’t have a broken download so you end up with a corrupted archetype in your local maven repository?

Also, which version of maven do you use?

Indeed I think my archetype is incorrect, I don’t see any other explanation.
I actually use maven 3.2.3

It seems the most likely explanation, yes.
I just ran it on my machine and everything went fine.