Recording is not working

I am using Gatling bundle open source code. I have installed it by downloading it and launching the Gatling UI from recorder.bat file. I am following documentation and want to record the browsing activities of website (mentioned in the documentation) Computers database … I have done HTTP Proxy setting in the Firefox also but still the file is not getting created after the browsing of above website. I have clicked on start button and then browsed the website and created new record. Deleted few records as well and then stopped it.

Any error in the console?
Is the target application running on localhost or on a remote server?

It is local server and below is the error:

GATLING_HOME is set to “C:\D_Drive\gatling\source”
JAVA = java
GATLING_HOME is set to C:\D_Drive\gatling\source

09:01:08.451 [WARN ] i.n.c.DefaultChannelPipeline - An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.
io.netty.handler.ssl.ReferenceCountedOpenSslEngine$OpenSslHandshakeException: error:10000412:SSL routines:OPENSSL_internal:SSLV3_ALERT_BAD_CERTIFICATE

Your local server uses https but it seems with a self-signed certificate. If so, there’s a chance the proxy mode doesn 't work. In this case, try using the HAR one.

I have opened HTTP link and not S one. Also, I have enabled the HTTP PROXY setting in firefox and still not working. Let me HAR

Then are you sure you have properly removed localhost from your No proxy for config in FireFox (where you configured the proxy)?

I have attached the File for your reference. Also, I have tried by checked the box “Also use this proxy for HTTPS” … But still same issyue

I’m talking about this configuration. But it seems FireFox has changed this behavior and there’s now no way to use a proxy while requesting on localhost. Stupid change really. So I’m afraid you’ll have to either go with the HAR mode or use an entry in your /etc/hosts file to use an alternate name for your local machine.

In the “No proxy for” there is no value. That Textarea is blank. Let me try with HAR mode. Is it possible to do with Chrome? Also, can we use Gatling with Database Stress load. Not UI Database but directly with SQL scripts?

Is it possible to do with Chrome?

Why wouldn’t it be possible? Also, there are ton of browser plugin for configuring proxies that might help.

Also, can we use Gatling with Database Stress load. Not UI Database but directly with SQL scripts?

Different topic. Please create a new thread.

There are two images in the screen shot.
I have selected the HAR option from UI. And in the Chrome Developer Tool I have done the recording and end the recording as well. After that I have selected the one request and right click “Save all as HAR with Content”. File got generated and same File I have uploaded in the UI (recorder.bat) and got error “the selected file doesn’t contain any valid HTTP requests”

Nothing we can do unless you provide your HAR.

It is not allowing to upload the .har file.

There are tons of file sharing services you can use, eg Google Drive.

Your HAR works just fine for me. Do you have an error in the logs, as hinted in the error message? Which version of Gatling are you using?

I have downloaded the zip file: gatling-charts-highcharts-bundle-3.9.5-bundle

Do you have an error in the logs, as hinted in the error message?


There is no error in the command prompt. Only error message box popped up from the UI which I had sent the screenshot. I have attached the screenshot from CMD when error message box popped-up

Tested on Windows too, no issue on our side.

Note: I’ve renamed your file from to computer-database-gatling-io.har, could you also try that?