Requests timeout to not-connected

I’m experiencing an issue with request timeout on a test scenario for an ecommerce site.
Basically, after a while, I see a lot of exceptions of this kind appear on the gatling log:

"j.u.c.TimeoutException: Request timeout to not-connected after 60000 ms"

I’ve always seen other kinds of timeout exceptions like this:

j.u.c.TimeoutException: Request timeout to <url_of_site> after 60000 ms

and these one I was able to explain, since they were slow response from the site due to overload or other problems

but the "j.u.c.TimeoutException: Request timeout to not-connected after 60000 ms" what does it mean exactly? The gatling server wasn’t able to connect to the site?
Because on the infrastructure of the site I’ve checked all the metrics of the layers where I had visibility and it seems that there were no issues (cpu, memory were on a safe side, thread pools of apache and tomcat layers were not saturated, db was responding fine and so on), so I can’t really explain what was causing all these timeouts to occur. Honestly I’ve to say that I have no visibility on the load balancer that stays in front of the Apache web servers and that is the layer we connect to, but the network engineers that I’ve contacted said me that there were no issue on the balancer and I have to trust them…(or not?)
Something else that I’ve noticed is that, these exceptions are more present in the first steps of the navigation scenario, like homePage and Login in my case.

However, I’d like to understand a bit more like when is this exception raised by the gatling client and other details if someone can provide.


Hi again,

Could you please upgrade to Gatling 3.0.0-RC3?
Can’t say if it’s an issue on your side or in the HTTP client that we were using in Gatling 2. We have a brand HTTP client in Gatling 3.


Hi Stéphane,
thanks for the advice…it worked. I’m not sure if was the upgrade that solved the issue or if it was related to the other issue I’ve opened of users never ending the simulation because of redirect loops that by the way was solved again with the update to 3.0 version…anyway it seems that there are no more those kinds of exceptions and now I just have from time to time “normal” timeout exceptions when the site is a bit overloaded.

Thanks for your feedback.
Frankly, our new internal HTTP client is pretty promising and way more sound than the old one in Gatling 2.