Set own "binaries" at configuration does not work properly

I tried to set the “binaries” configuration to change the “target” directory. Without this setting the simulation works just fine (got compiled at GATLING_HOME/target and started normally).
But otherwise I get:

Exception in thread “main” java.lang.ClassNotFoundException: loadtest.TestSimulation
at$ Source)

Here’re my settings:

gatling {
simulation {
class = loadtest.TestSimulation
directory {
data = …/src/loadtest/resources/data
requestBodies = …/src/loadtest/resources/request-bodies
simulations = …/src/loadtest/scala
results = …/target/loadtest/results
binaries = …/target/loadtest

Regards Danny

How do you run? From the command line, from the maven plugin?

Currently I run it over the command line (the maven plugin is planned to be used later).

In your case, you shouldn’t force the binaries folder. It’s used to tell Gatling that the classes have already been compiled, and where, and that it should skip the compiling phase. It’s intended for the projects generated from the maven archetype, where compiling is done by the IDE.

Thanks for the advice.
Furthermore if I use the maven plugin I don’t need to use this config anymore (seen in the documentation).

Regards Danny